US2 Backdrop - Intermittent Errors
Incident Report for backdrop
Resolved
This incident has been resolved.
Posted Apr 11, 2024 - 19:41 BST
Investigating
We are currently investigating this issue.
Posted Apr 11, 2024 - 19:26 BST
This incident affected: US2.